AMD64

Fehler und Wünsche zum Projekt yoyo@home
Bugs and wishes for the project yoyo@home
Nachricht
Autor
Benutzeravatar
Augustine
Mikrocruncher
Mikrocruncher
Beiträge: 27
Registriert: 13.08.2007 15:56

AMD64

#1 Ungelesener Beitrag von Augustine » 16.08.2007 16:38

Since you've asked, a native x86-64 client would be cool. Some BOINC projects experienced significant performance improvements when their applications were ported to x86-64.

I ported SETI Classic to x86-64 and helped out several projects in their porting efforts, such as Chess960 and Predictor, and I'd be glad to be of service.
Bild

Benutzeravatar
yoyo
Vereinsvorstand
Vereinsvorstand
Beiträge: 7749
Registriert: 17.12.2002 14:09
Wohnort: Berlin
Kontaktdaten:

#2 Ungelesener Beitrag von yoyo » 16.08.2007 19:07

Hello,
thx for your offer. But I use existing applications and include these with the Boinc wrapper. There is no application for windows64 because there is not performance improvement of it.
Here is the list of clients which can be included:
http://distributed.net/download/clients.php
yoyo
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Bild Bild

Benutzeravatar
Augustine
Mikrocruncher
Mikrocruncher
Beiträge: 27
Registriert: 13.08.2007 15:56

#3 Ungelesener Beitrag von Augustine » 28.08.2007 23:53

But x86-64 Linux is supported according to the info in the link above (AMD64/ELF). Or am I missing something?

Thanks.
Bild

Benutzeravatar
yoyo
Vereinsvorstand
Vereinsvorstand
Beiträge: 7749
Registriert: 17.12.2002 14:09
Wohnort: Berlin
Kontaktdaten:

#4 Ungelesener Beitrag von yoyo » 29.08.2007 08:53

Hello,
I added the AMD64 version for Linux. I use the 32bit version of wrapper which calls the 64bit version of cruncher. Hope this works.
yoyo
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Bild Bild

Benutzeravatar
Augustine
Mikrocruncher
Mikrocruncher
Beiträge: 27
Registriert: 13.08.2007 15:56

#5 Ungelesener Beitrag von Augustine » 17.12.2007 20:26

Even though there's an official AMD64 client for Linux, it refers to too many dynamic libraries and requires a fairly recent Linux setup to run on.

So, one more time, I'm making available the AMD64 Linux client here. It refers to a minimal set of standard dynamic libraries whose version requirements should be satisfied by Linux systems up to 2 or 3 years old, however it was built with a fairly recent version of GCC, 4.1.2.

The drill's still the same: The official AMD64 Windows client can be found here.

For more information, see the BoincStats Forum.

HTH
Bild

Antworten

Zurück zu „Fehler, Wünsche / Bugs, Wishes“