Wiki-Programmierung - Hilfe benötigt

Eure Kommentare, Anregungen und Wünsche zu dieser Webseite und dem Forum

Wiki-Programmierung - Hilfe benötigt

Unread postby Der Diplomat » 24.10.2018 18:29

Hallo zusammen,

kennt sich jemand mit der MediaWiki-Software aus?

Mir geht es gerade um folgende Lösungsfindung:
Yafu Wie man dort sieht, werden die Bilder einer anderen url nicht angezeigt.
Unter html würde ich programmieren <img src="">
Unter wiki programmiert man [FILE:x.png]. Allerdings funktioniert dieser Befehl nur, wenn das Bild auch in einem Wiki-Verzeichnis hinterlegt ist.
Wie kann man also die Seite dazu bringen, die Bilder einer anderen URL auch anzuzeigen und nicht nur zu verlinken? Laut Mediawiki eben mit der url ohne Brackets oder sonstiger Befehle. Aber genau das passiert dort nicht.

Jemand eine Lösung parat?
User avatar
Der Diplomat
Powerknopf-Verweigerer
Powerknopf-Verweigerer
 
Posts: 1463
Joined: 21.07.2001 01:00
Location: Coburg

Re: Wiki-Programmierung - Hilfe benötigt

Unread postby yoyo » 24.10.2018 19:09

Ich glaub jetzt gehts.
Hab was umkonfiguriert und externe Images von yafu erlaubt.

Der Diplomat wrote:Hallo zusammen,

kennt sich jemand mit der MediaWiki-Software aus?

Mir geht es gerade um folgende Lösungsfindung:
Yafu Wie man dort sieht, werden die Bilder einer anderen url nicht angezeigt.
Unter html würde ich programmieren <img src="">
Unter wiki programmiert man [FILE:x.png]. Allerdings funktioniert dieser Befehl nur, wenn das Bild auch in einem Wiki-Verzeichnis hinterlegt ist.
Wie kann man also die Seite dazu bringen, die Bilder einer anderen URL auch anzuzeigen und nicht nur zu verlinken? Laut Mediawiki eben mit der url ohne Brackets oder sonstiger Befehle. Aber genau das passiert dort nicht.

Jemand eine Lösung parat?
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Image Image
User avatar
yoyo
Vereinsvorstand
Vereinsvorstand
 
Posts: 7647
Joined: 17.12.2002 14:09
Location: Berlin

Re: Wiki-Programmierung - Hilfe benötigt

Unread postby Der Diplomat » 30.10.2018 15:24

Hallo zusammen,

kennt sich jemand mit dem MetaWiki und den RSS-Befehlen aus?

Auf diese Projektseite bekomme ich die RSS-Nachrichten nicht eingebunden:
DENIS

Verwendete Vorlagen:
Vorlage:RSS
Vorlage:RSS Inline
User avatar
Der Diplomat
Powerknopf-Verweigerer
Powerknopf-Verweigerer
 
Posts: 1463
Joined: 21.07.2001 01:00
Location: Coburg

Re: Wiki-Programmierung - Hilfe benötigt

Unread postby yoyo » 31.10.2018 21:39

Ich glaub der RSS Parser kommt mit dem RSS von DENIS nicht klar.
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Image Image
User avatar
yoyo
Vereinsvorstand
Vereinsvorstand
 
Posts: 7647
Joined: 17.12.2002 14:09
Location: Berlin

Re: Wiki-Programmierung - Hilfe benötigt

Unread postby Der Diplomat » 01.11.2018 16:46

Die alten RSS-Vorlagen sind auf alte .php Seiten abgestimmt, eren Endungen auch in der URL angegeben werden.

Die neuen wie z.B. bei WCG arbeiten etwas anders, dort reicht es ein ?rss=1 einzutragen und es funktioniert.
Soweit bin ich gekommen.

Wie man aber das RSS-Angebot von Denis in der dort benutzten Version programmieren muss, weiß ich nicht. Vielleicht hat ja sonst ein Besucher des Forums eine Idee?
User avatar
Der Diplomat
Powerknopf-Verweigerer
Powerknopf-Verweigerer
 
Posts: 1463
Joined: 21.07.2001 01:00
Location: Coburg

Re: Wiki-Programmierung - Hilfe benötigt

Unread postby Der Diplomat » 09.11.2018 02:53

Keiner eine Idee?

Bei Gerasim wird zwar wenigstens etwas angezeigt, aber auch dort werden die Nachrichten nicht richtig angezeigt.

<rss date="(d.m.Y)"> wurde auch schon versucht, bringt jedoch kein anderes Ergebnis.
User avatar
Der Diplomat
Powerknopf-Verweigerer
Powerknopf-Verweigerer
 
Posts: 1463
Joined: 21.07.2001 01:00
Location: Coburg

Re: Wiki-Programmierung - Hilfe benötigt

Unread postby yoyo » 09.11.2018 21:50

Bei Gerasim fehlte nur das Date. Das konnte nicht aus dem RSS geparst werden. Das hab ich gefixt.
Dass im Titel nur "Gerasim@home:" steht liegt an Gerasim selbst. Sieht man sich den rss Feed (http://gerasim.boinc.ru/rss_main.aspx) mal an was da kommt (z.B. in Chrome), steht unter <title> auch nicht mehr.

Wenn man sich den Denis rss Feed z.B. in Chrome oder IE ansieht (https://denis.usj.es/en_US/category/ong ... ects/feed/), merkt man dass die erste Zeile fehlt. Ich glaub deswegen fällt der XML Parser um. Mal sehen ob ich finde wo man das fixen kann.

Weiß zufällig jemand wie man in php Leerzeilen wegfiltern/löschen kann?
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Image Image
User avatar
yoyo
Vereinsvorstand
Vereinsvorstand
 
Posts: 7647
Joined: 17.12.2002 14:09
Location: Berlin


Return to Ankündigungen und Feedback zur Webseite und dem Wiki

Who is online

Users browsing this forum: No registered users and 13 guests