langsamer Webserver

Eure Kommentare, Anregungen und Wünsche zu dieser Webseite und dem Forum
Nachricht
Autor
Benutzeravatar
yoyo
Vereinsvorstand
Vereinsvorstand
Beiträge: 8052
Registriert: 17.12.2002 14:09
Wohnort: Berlin
Kontaktdaten:

langsamer Webserver

#1 Ungelesener Beitrag von yoyo » 27.04.2024 17:23

Hallo,

seit einigen Tagen war das Forum manchmal sehr langsam. Grund war ein Amok laufender Webcrawler, der ClaudeBot/1.0, der massiv parallel von verschiedensten IP Adresssen sich das Forum durchgelesen hat. Das hat dazu geführt dass alle 150 Apache Prozesse belegt waren und normale Anfragen kaum noch dran kamen. Eigentlich ein DDOS Angriff.
Ich hab heute morgen durch eine Regeln im Apache ihn direkt nach China zu Huawei auf die Seite redirekted.
Dadurch konnte direkt der Apache schnell die Anfrage beantworten ohne auf Forum und DB zugreifen zu müssen.
Sofort waren dann auch wieder Apache Prozesse frei.
Mittlerweile kommt der Bot jetzt garnicht mehr vorbei, hot wohl genug von den Chinesen.

yoyo
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Bild Bild

Benutzeravatar
Kolossus
TuX-omane
TuX-omane
Beiträge: 4401
Registriert: 26.10.2014 14:51

Re: langsaer Webserver

#2 Ungelesener Beitrag von Kolossus » 28.04.2024 00:19

yoyo hat geschrieben:
27.04.2024 17:23
Mittlerweile kommt der Bot jetzt garnicht mehr vorbei, hot wohl genug von den Chinesen.
Auch Bots haben wohl ihren Stolz.
Wie hast du denn den Angreifer identifizieren können?
Gruß Harald
Selbst wenn es die Sonne ist, die auf ihn scheint, ein Misthaufen antwortet immer nur mit Gestank...Bild
Bild

Benutzeravatar
yoyo
Vereinsvorstand
Vereinsvorstand
Beiträge: 8052
Registriert: 17.12.2002 14:09
Wohnort: Berlin
Kontaktdaten:

Re: langsaer Webserver

#3 Ungelesener Beitrag von yoyo » 28.04.2024 07:17

Ich hab währenddessen das Apache Logfile mitlaufen lassen und gesehen, dass da Unmengen an Zugriffen von jemandem kommen, der sich im UserAgent "ClaudeBot/1.0" nennt und der das ganze Forum ständig abfragt.
HILF mit im Rechenkraft-WiKi, dies gibts zu tun.
Wiki - FAQ - Verein - Chat

Bild Bild

Stiwi
Powerknopf-Verweigerer
Powerknopf-Verweigerer
Beiträge: 1424
Registriert: 20.05.2012 21:11

Re: langsaer Webserver

#4 Ungelesener Beitrag von Stiwi » 28.04.2024 11:30

Ist ja im dem Sinne auch kein richtiger Angriff gewesen sondern einfach nur der dumme Bot von Anthropic für deren KI.
Es scheint auch so zu sein dass dieser Bot die robots.txt ignoriert. Ich hoffe irgendwer verklagt diese Firma dafür....

https://www.reddit.com/r/singularity/co ... aping_the/

Das Problem mit dem Bot scheinen die letzten Tage viele gehabt zu haben
Bild
Bild

Benutzeravatar
Kolossus
TuX-omane
TuX-omane
Beiträge: 4401
Registriert: 26.10.2014 14:51

Re: langsaer Webserver

#5 Ungelesener Beitrag von Kolossus » 28.04.2024 13:11

Hallo Stiwi,
meiner unmaßgeblichen Meinung nach war das aber schon recht heftig, was da los war. Die Seite aufzurufen dauerte recht lange, dass man schon Zeitüberschreitungsfehler fürchtete.
Wir können froh sein, dass sich yoyo zu helfen wusste. Es ist einfach eine Sauerei, was da zeitweise abgeht.
Mir war nur immer wieder aufgefallen, dass in letzter Zeit die Zahl der „Gäste“ im Forum ungewöhnlich hoch war, teilweise über einhundert im selben Fred.
Ob es da einen Zusammenhang gibt, entzieht sich allerdings meiner Kenntnis.
Gruß Harald
Selbst wenn es die Sonne ist, die auf ihn scheint, ein Misthaufen antwortet immer nur mit Gestank...Bild
Bild

Stiwi
Powerknopf-Verweigerer
Powerknopf-Verweigerer
Beiträge: 1424
Registriert: 20.05.2012 21:11

Re: langsaer Webserver

#6 Ungelesener Beitrag von Stiwi » 28.04.2024 17:07

Ich wollte mit meinem Post auch nichts relativieren. Nur aussagen dass es kein Angriff war sondern ein dumm konfigurierter Bot von einer KI Firma. Und da das so ne sauerei ist hoffe ich die werden verklagt
Bild
Bild

Benutzeravatar
gemini8
Vereinsvorstand
Vereinsvorstand
Beiträge: 6044
Registriert: 31.05.2011 10:30
Wohnort: Hannover

Re: langsamer Webserver

#7 Ungelesener Beitrag von gemini8 » 28.04.2024 22:10

Faktisch kann man diese dumme Programmiererei aber mit einem dDoS Angriff gleichsetzen.
Hoffentlich lassen die ihr sich selbst überprüfendes LLM mal auf seine Art und Weise los, sich Daten zu verschaffen.
Nach der Überprüfung dürfte das Ding dann entweder 'vernünftiger' mit anderer Leute Ressourcen umgehen oder zeigen, dass es doch nicht das kann, was es können soll.
Gruß, Jens
- - - - - -
Lowend-User und Teilzeit-Cruncher

Bild Bild Bild
Bild

Benutzeravatar
gemini8
Vereinsvorstand
Vereinsvorstand
Beiträge: 6044
Registriert: 31.05.2011 10:30
Wohnort: Hannover

Re: langsamer Webserver

#8 Ungelesener Beitrag von gemini8 » 28.04.2024 22:15

Ach, yoyo:
Huawais Petalbot kannst du auch gleich zurück umleiten. Der bremst wohl gerade.
Gruß, Jens
- - - - - -
Lowend-User und Teilzeit-Cruncher

Bild Bild Bild
Bild

Benutzeravatar
Kolossus
TuX-omane
TuX-omane
Beiträge: 4401
Registriert: 26.10.2014 14:51

Re: langsaer Webserver

#9 Ungelesener Beitrag von Kolossus » 28.04.2024 23:23

Stiwi hat geschrieben:
28.04.2024 17:07
Ich wollte mit meinem Post auch nichts relativieren.....
Das wollte ich auch nicht zum Ausdruck gebracht haben, verzeih, wenn das bei dir so angekommen ist. :wink:
Gruß Harald
Selbst wenn es die Sonne ist, die auf ihn scheint, ein Misthaufen antwortet immer nur mit Gestank...Bild
Bild

Antworten

Zurück zu „Ankündigungen und Feedback zur Webseite und dem Wiki“